More

    Cara Install Mikrotik CHR (Cloud Host Router) pada Centos 8

    Cara Install Mikrotik CHR – Mikrotik seringkali diperlukan ketika mengelola sebuah network secara fisik atau virtual. Saat ini, Mikrotik tersedia dalam versi cloud yang bernama Mikrotik CHR. Sistem operasi ini memungkinkan kamu untuk bisa menginstal Mikrotik CHR pada VPS atau server yang kamu miliki. Di artikel ini, kamu akan mempelajari bagaimana cara meng-install Mikrotik CHR di CentOS 8.

    Mikrotik CHR

    Mikrotik Cloud Hosted Router atau disingkat Mikrotik CHR adalah versi RouterOS yang didesain khusus agar sebuah perangkat komputer dapat dijalankan secara virtual di Virtual Machine (VM). CHR menggunakan arsitektur x86 64-bit dan bisa digunakan pada sebagian besar hypervisor, seperti VMWare, HyperV, atau VirtualBox.

    Mikrotik CHR sama seperti RouterOS biasanya, kecuali level lisensinya. Tapi tenang saja, kita tetap bisa menggunakan CHR dengan lisensi gratis, walaupun kecepatan traffic dengan lisensi gratis hanya akan dibatas pada 1 Mbit per interface.

    Tapi, sebelum melakukan installasi CHR di VPS. Kita harus membuat VPS Cloudnya terlebih dahulu. Provider yang akan saya gunakan kali ini adalah VULTR. Karena di vultr ada VPS termurah yaitu 3,5$/month. Ada juga yang 2,5$/month, tapi di instance tersebut tidak didukung ipv4 dan hanya mendukung ipv6 saja.

    Jika kamu belum mempunyai akun vultr, silahkan gunakan link berikut Vultr Sign Up. Dengan daftar menggunakan link tersebut anda akan mendapatkan free $100 untuk mencoba layanan vultr.

    Membuat Instance Baru di Vultr

    1. Klik Product lalu klik Deploy InstanceCara Install Mikrotik CHR

    2. Lalu pilih Cloud Compute pada Server Location pilih America pada lokasi pilih New York(NJ) Cara Install Mikrotik CHR

    3. Pada Server Type Pilih Centos dengan versi 8 x64Cara Install Mikrotik CHR

    4. Pada Server Size pilih yangg $3.5/Month

    5. Lalu jangan lupa isi hostname dan label. Jika sudah klik Deploy NowCara Install Mikrotik CHR

    Proses deploy akan membutuhkan waktu setidaknya 5-10 menit.

    Cara Install Mikrotik CHR (Cloud Host Router)

    Berikut ini adalah cara install Mikrotik CHR untuk VPS dengan sistem operasi CentOS 8.

    Langkah install :

    • Update Server
    • Install Firewall
    • Download Mikrotik CHR
    • Mount Mikrotik CHR
    • Testing

    Baca juga : Bagaimana Cara Mendapatkan Credit $10 Gratis dari Digital Ocean?

    Update Server

    Pertama, pastikan terlebih dulu apakah server sudah diperbarui, tujuannya adalah agar package yang akan digunakan ikut diperbarui juga. Kemudian lakukan reboot server.

    yum update -y 
    reboot

     

    Install Firewall

    Firewall yang digunakan dalam cara install Mikrotik di CentOS 8 ini adalah CSF (ConfigServer Security & Firewall). Instalasi CSF Firewall di CentOS 8 sedikit berbeda dengan OS lain.

    cd /usr/src
    wget https://download.configserver.com/csf.tgz 
    tar -xzf csf.tgz

    Install & Create directory iptables

    yum install iptables-services -y
    touch /etc/sysconfig/iptables
    touch /etc/sysconfig/iptables6

    Install CSF

    csf csf/
    install.sh
    perl /usr/local/csf/bin/csftest.pl

    Edit csf.conf lalu ubah value make TESTING menjadi 0.

    nano /etc/csf/csf.conf
    
    make TESTING=’0’

    Setelah itu simpan dan keluar.

    Kemudian, reload CSF dengan perintah berikut.

    csf -r

     

    Download Mikrotik CHR

    Install beberapa package yang dibutuhkan untuk keperluan instalasi Mikrotik CHR di CentOS 8 ini, kemudian unduh package Mikrotik CHR dengan pilihan Raw Disk Image, di sini kami menggunakan versi yang sudah stabil, yaitu v6.48.6.

    yum install wget unzip -y
    wget https://download.mikrotik.com/routeros/6.48.6/chr-6.48.6.img.zip -O mik-chr.img.zip

    Perintah di atas berarti kamu akan mengunduh menggunakan wget dan menyimpannya dengan nama mik-chr-.img.zip. Jika sudah terunduh, unzip atau extract file .zip tersebut dan list.

    unzip mik-chr.img.zip
    ls 
    --output--
    chr-6.47.6.img  mik-chr.img.zip

    Artinya proses unzip sudah selesai.

    Mount Mikrotik CHR

    Lakukan mount pada file chr-xxxx.img ke direktori /mnt dengan perintah di bawah ini.

    mount -o loop,offset=512 chr-xxxx.img /mnt

    Sesuaikan nama “xxxx” dengan file CHR yang kamu miliki. Kemudian, verifikasikan hasil mount yang dilakukan tadi dengan perintah berikut ini.

    ls /mnt
    ---output---
    bin  boot  dev  lost+found  nova  rw  SHOW_LICENSE  UPGRADED  var

    Setelah itu, buat sejumlah perintah pada CLI untuk mengatur addressing dari alamat IP pada interface ether1, default route, dan server DNS dari Mikrotik CHR yang dapat dieksekusi dengan perintah echo. Kemudian sejumlah perintah tersebut akan disimpan dalam file autorun.scr yang terdapat pada direktori /mnt/rw/. Perintahnya akan terlihat seperti di bawah ini.

    Copy dan paste saja perintah dibawah ini ke terminal.

    ADDRESS=`ip addr show eth0 | grep global | cut -d' ' -f 6 | head -n 1` && \
    GATEWAY=`ip route list | grep default | cut -d' ' -f 3` && \
    echo "/ip address add address=$ADDRESS interface=[/interface ethernet find where name=ether1]
    /ip route add gateway=$GATEWAY
    /ip dns set servers=8.8.8.8,8.8.4.4" > /mnt/rw/autorun.scr

    Verifikasikan apakah perintah-perintah tersebut sudah tertulis di dalam file autorun.scr atau belum.

    cat /mnt/rw/autorun.scr
    /ip address add address=103.xxx interface=[/interface ethernet find where name=ether1] 
    /ip route add gateway=103.xxx
    /ip dns set servers=8.8.8.8,8.8.4.4

    Bagian address=103.xxx ini nantinya akan sesuai dengan alamat IP di VPS kamu. Mengingat proses mounting sudah selesai, maka kamu bisa melepas mount (unmout) dengan perintah:

    echo u > /proc/sysrq-trigger

    Kemudian salin seluruh isi dan berkas dari images CHR tadi ke /dev/vda menggunakan perintah dd (disk dump) seperti di bawah ini.

    dd if=chr-6.47.6.img bs=1024 of=/dev/vda
    ---output---
    65536+0 records in
    65536+0 records out
    67108864 bytes (67 MB, 64 MiB) copied, 4.20313 s, 16.0 MB/s

    Sesuaikan versi CHR dengan file yang kamu unduh tadi menggunakan perintah wget. Kemudian reboot VPS menggunakan perintah reboot.

    reboot

     

    Testing

    Setelah reboot, anda bisa mengakses mikrotik CHR dengan memasukkan alamat ip server anda. untuk username : admin dan password : (kosong).cara install mikrotik chr

    Dengan mikrotik CHR tersebut anda bisa melakukan banyak hal, antara lain yaitu anda bisa me-remote mikrotik yang ada di rumah/kantor dari jaringan luar dengan terhubung dengan VPN atau jika anda mempunyai mikrotik di beberapa tempat anda bisa membuat mikrotik tersebut terhubung satu sama lain.

    Selain itu, anda juga bisa me-remote access point dari luar jaringan dan masih banyak lagi.

    Untuk tutorialnya akan saya bahas pada artikel berikutnya.

    Free $100
    Deal

    Daftar menggunakan link di pojok kanan atas, minimal top up $25 usd. Maka dalam waktu 30 hari setelah registrasi anda akan mendapatkan credit $100 gratis dari vultr untuk mencoba layanan mereka.

    More Less
    Doesn't expire

    Recent Articles

    apa itu mirkotik

    Apa itu Mikrotik dan Fungsinya

    0
    Apa itu mikrotik? - Untuk beberapa orang yang biasa berkecimpung di dunia jaringan, mungkin sudah tidak asing lagi dengan yang namanya Mikrotik. Alat tersebut biasa ada...
    aplikasi belajar online

    Moodle, Aplikasi Belajar Online Gratis

    0
    Aplikasi Belajar Online - Saat ini membuat aplikasi pembelajaran online sangatlah mudah. Banyak sekali platform yang bisa anda gunakan untuk pembelajaran online, salah satunya...
    cara install mikrotik CHR

    Cara Install Mikrotik CHR (Cloud Host Router) pada Centos 8

    0
    Cara Install Mikrotik CHR - Mikrotik seringkali diperlukan ketika mengelola sebuah network secara fisik atau virtual. Saat ini, Mikrotik tersedia dalam versi cloud yang bernama Mikrotik CHR. Sistem operasi...
    upgrade windows 11

    Cara Upgrade Windows 11 Gratis!

    0
    Pada tanggal 5 Oktober 2021, microsoft telah resmi meluncurkan generasi windowsnya yaitu windows 11. Dengan serangkaian fitur baru, Windows 11 diklaim akan menyajikan pengalaman menggunakan...
    tips memilih isp

    Tips Memilih ISP Untuk Kebutuhan Internet Anda

    0
    Dalam memilih ISP kita perlu mempertimbangkan beberapa hal, diantaranya ialah budget. Namun, selain itu tentunya kita perlu memilih isp yang cocok dengan kita. Memilih ISP...

    Related Articles

    Leave A Reply

    Please enter your comment!
    Please enter your name here

    This site uses Akismet to reduce spam. Learn how your comment data is processed.

    Dapatkan konten terbaik dari kami!